using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\d+(?:\.\d+){2})\d*\.?\d*\/?\d*\.?\d*[a-z]*$";
string input = @"Here are some examples that can pass:
23.23/100km
1/3
.23km
1.mi
1.2/2.1kg
Some examples that shouldn't pass:
1a3km
12.12.12
1.2.3/12.13km
12km/12.44km";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}