import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\d+(?:\\.\\d+){2})\\d*\\.?\\d*\\/?\\d*\\.?\\d*[a-z]*$";
final String string = "Here are some examples that can pass:\n"
+ "23.23/100km\n"
+ "1/3\n"
+ ".23km\n"
+ "1.mi\n"
+ "1.2/2.1kg\n"
+ "Some examples that shouldn't pass:\n"
+ "1a3km\n"
+ "12.12.12\n"
+ "1.2.3/12.13km\n"
+ "12km/12.44km";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}