import re
regex = re.compile(r"^(?!.*\d+(?:\.\d+){2})\d*\.?\d*\/?\d*\.?\d*[a-z]*$", flags=re.MULTILINE)
test_str = ("Here are some examples that can pass:\n"
"23.23/100km\n"
"1/3\n"
".23km\n"
"1.mi\n"
"1.2/2.1kg\n"
"Some examples that shouldn't pass:\n"
"1a3km\n"
"12.12.12\n"
"1.2.3/12.13km\n"
"12km/12.44km")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")