$re = '/^(?!.*\d+(?:\.\d+){2})\d*\.?\d*\/?\d*\.?\d*[a-z]*$/m';
$str = 'Here are some examples that can pass:
23.23/100km
1/3
.23km
1.mi
1.2/2.1kg
Some examples that shouldn\'t pass:
1a3km
12.12.12
1.2.3/12.13km
12km/12.44km';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);