const regex = /^(?!.*\d+(?:\.\d+){2})\d*\.?\d*\/?\d*\.?\d*[a-z]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\d+(?:\\.\\d+){2})\\d*\\.?\\d*\\\/?\\d*\\.?\\d*[a-z]*$', 'gm')
const str = `Here are some examples that can pass:
23.23/100km
1/3
.23km
1.mi
1.2/2.1kg
Some examples that shouldn't pass:
1a3km
12.12.12
1.2.3/12.13km
12km/12.44km`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}