using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\/page\/([0-9]+))?";
string input = @"remote-jobs
remote-php-jobs
remote-php+laravel-jobs
remote-jobs-in-oceania
remote-jobs-in-oceania+worldwide
remote-php-jobs-in-oceania+worldwide
remote-php+laravel-jobs-in-oceania+worldwide
remote-jobs-in-oceania-from-20k-usd
remote-jobs-in-oceania+worldwide-from-20k-usd
remote-php-jobs-in-czech-republic+worldwide-from-20k-usd
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd
remote-jobs-in-oceania-from-20k-usd/page/2
remote-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}