import re
regex = re.compile(r"remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\/page\/([0-9]+))?", flags=re.MULTILINE)
test_str = ("remote-jobs\n\n"
"remote-php-jobs\n"
"remote-php+laravel-jobs\n\n"
"remote-jobs-in-oceania\n"
"remote-jobs-in-oceania+worldwide\n"
"remote-php-jobs-in-oceania+worldwide\n"
"remote-php+laravel-jobs-in-oceania+worldwide\n\n"
"remote-jobs-in-oceania-from-20k-usd\n"
"remote-jobs-in-oceania+worldwide-from-20k-usd\n"
"remote-php-jobs-in-czech-republic+worldwide-from-20k-usd\n"
"remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd\n\n"
"remote-jobs-in-oceania-from-20k-usd/page/2\n"
"remote-jobs-in-oceania+worldwide-from-20k-usd/page/2\n"
"remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2\n"
"remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")