import Foundation
let pattern = #"remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\/page\/([0-9]+))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
remote-jobs
remote-php-jobs
remote-php+laravel-jobs
remote-jobs-in-oceania
remote-jobs-in-oceania+worldwide
remote-php-jobs-in-oceania+worldwide
remote-php+laravel-jobs-in-oceania+worldwide
remote-jobs-in-oceania-from-20k-usd
remote-jobs-in-oceania+worldwide-from-20k-usd
remote-php-jobs-in-czech-republic+worldwide-from-20k-usd
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd
remote-jobs-in-oceania-from-20k-usd/page/2
remote-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)