const regex = /remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\/page\/([0-9]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\\\/page\\\/([0-9]+))?', 'gm')
const str = `remote-jobs
remote-php-jobs
remote-php+laravel-jobs
remote-jobs-in-oceania
remote-jobs-in-oceania+worldwide
remote-php-jobs-in-oceania+worldwide
remote-php+laravel-jobs-in-oceania+worldwide
remote-jobs-in-oceania-from-20k-usd
remote-jobs-in-oceania+worldwide-from-20k-usd
remote-php-jobs-in-czech-republic+worldwide-from-20k-usd
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd
remote-jobs-in-oceania-from-20k-usd/page/2
remote-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}