#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+)?234[0-9]*?.*"
Local $sString = "0000 000 0000" & @CRLF & _
"01 000 0000" & @CRLF & _
"+234 1 000 0000" & @CRLF & _
"0000-000-0000" & @CRLF & _
"00000000000" & @CRLF & _
"234 000 000 0000" & @CRLF & _
"234(000)000-0000" & @CRLF & _
"234(000)000 0000" & @CRLF & _
"+234(000)000 0000" & @CRLF & _
"+234(000) 000 0000" & @CRLF & _
"+234(000)000-0000" & @CRLF & _
"2340000000000" & @CRLF & _
"+2340000000000" & @CRLF & _
"55523456565"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")