re = /^(\+)?234[0-9]*?.*/m
str = '0000 000 0000
01 000 0000
+234 1 000 0000
0000-000-0000
00000000000
234 000 000 0000
234(000)000-0000
234(000)000 0000
+234(000)000 0000
+234(000) 000 0000
+234(000)000-0000
2340000000000
+2340000000000
55523456565'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end