import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+)?234[0-9]*?.*";
final String string = "0000 000 0000\n"
+ "01 000 0000\n"
+ "+234 1 000 0000\n"
+ "0000-000-0000\n"
+ "00000000000\n"
+ "234 000 000 0000\n"
+ "234(000)000-0000\n"
+ "234(000)000 0000\n"
+ "+234(000)000 0000\n"
+ "+234(000) 000 0000\n"
+ "+234(000)000-0000\n"
+ "2340000000000\n"
+ "+2340000000000\n"
+ "55523456565";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}