package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\D]+[^\W\d_a-jln-z]?$`)
var str = `2323
23234k
23234m
23234$
23234a
k
m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}