import re
regex = re.compile(r"^[^\D]+[^\W\d_a-jln-z]?$", flags=re.MULTILINE)
test_str = ("2323\n"
"23234k\n"
"23234m\n\n"
"23234$\n"
"23234a\n"
"k\n"
"m")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")