const regex = /^[^\D]+[^\W\d_a-jln-z]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\D]+[^\\W\\d_a-jln-z]?$', 'gm')
const str = `2323
23234k
23234m
23234\$
23234a
k
m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}