# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*id_token=(.*?)&.*/$1/gm;t' <<< "http://localhost:8080/callback#id_token=eyJ...&access_token=eyJ...&expires_in=3600&token_type=Bearer&state=xxx"