const regex = /.*id_token=(.*?)&.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*id_token=(.*?)&.*', 'gm')
const str = `http://localhost:8080/callback#id_token=eyJ...&access_token=eyJ...&expires_in=3600&token_type=Bearer&state=xxx`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);