import re
regex = re.compile(r".*id_token=(.*?)&.*", flags=re.MULTILINE)
test_str = "http://localhost:8080/callback#id_token=eyJ...&access_token=eyJ...&expires_in=3600&token_type=Bearer&state=xxx"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)