$re = '/.*id_token=(.*?)&.*/m';
$str = 'http://localhost:8080/callback#id_token=eyJ...&access_token=eyJ...&expires_in=3600&token_type=Bearer&state=xxx';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;