package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*id_token=(.*?)&.*`)
var str = `http://localhost:8080/callback#id_token=eyJ...&access_token=eyJ...&expires_in=3600&token_type=Bearer&state=xxx`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}