package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$(\d+)\.(\d+)`)
var str = `$4.500`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}