use strict;
my $str = '$4.500';
my $regex = qr/\$(\d+)\.(\d+)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";