import re
regex = re.compile(r"\$(\d+)\.(\d+)", flags=re.MULTILINE)
test_str = "$4.500"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)