const regex = /\$(\d+)\.(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(\\d+)\\.(\\d+)', 'gm')
const str = `\$4.500`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);