# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\)(['"])(?:(?!(?:\1|\\)).|\\.)*+\1(*SKIP)(*FAIL)|\h+//gm;t' <<< "abc | xx ?? \"1 x \' 3\" d e f \' y \" 5 \' x yz
abc | xx ?? '1 x \\" 3' d e f \' y \" 5 \' x yz
"