#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\\)(['"])(?:(?!(?:\1|\\)).|\\.)*+\1(*SKIP)(*FAIL)|\h+"
Local $sString = "abc | xx ?? "1 x \' 3" d e f \' y " 5 \' x yz" & @CRLF & _
"" & @CRLF & _
"abc | xx ?? '1 x \" 3' d e f \' y " 5 \' x yz" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)