import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(['\"])(?:(?!(?:\\1|\\\\)).|\\\\.)*+\\1(*SKIP)(*FAIL)|\\h+";
final String string = "abc | xx ?? \"1 x \\' 3\" d e f \\' y \" 5 \\' x yz\n\n"
+ "abc | xx ?? '1 x \\\" 3' d e f \\' y \" 5 \\' x yz\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}