# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\\)(['\"])(?:(?!(?:\1|\\)).|\\.)*+\1(*SKIP)(*FAIL)|\h+"
test_str = ("abc | xx ?? \"1 x \\' 3\" d e f \\' y \" 5 \\' x yz\n\n"
"abc | xx ?? '1 x \\\" 3' d e f \\' y \" 5 \\' x yz\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.