using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(['""])(?:(?!(?:\1|\\)).|\\.)*+\1(*SKIP)(*FAIL)|\h+";
string substitution = @"";
string input = @"abc | xx ?? ""1 x \' 3"" d e f \' y "" 5 \' x yz
abc | xx ?? '1 x \"" 3' d e f \' y "" 5 \' x yz
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}