#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^([\w\W]+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Дата ввода\3{0,}\]{0,})([\w\W]+)GROUP BY(.+)$"
Local $sString = "SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]" & @CRLF & _
" GROUP BY `Тип заканчивания`"
Local $sSubst = "$1$2$4 GROUP BY $5, $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)