re = /^([\w\W]+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Дата ввода\3{0,}\]{0,})([\w\W]+)GROUP BY(.+)$/
str = 'SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]
GROUP BY `Тип заканчивания`'
subst = '$1$2$4 GROUP BY $5, $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result