import re
regex = re.compile(r"^([\w\W]+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Дата ввода\3{0,}\]{0,})([\w\W]+)GROUP BY(.+)$", flags=re.DOTALL)
test_str = ("SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]\n"
" GROUP BY `Тип заканчивания`")
subst = "$1$2$4 GROUP BY $5, $2"
result = regex.sub(subst, test_str)
if result:
print(result)