$re = '/^([\w\W]+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Дата ввода\3{0,}\]{0,})([\w\W]+)GROUP BY(.+)$/s';
$str = 'SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]
GROUP BY `Тип заканчивания`';
$subst = "$1$2$4 GROUP BY $5, $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;