package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[?(?P<series>[^0-9]+)(?P<episode>\[?\d+\]?)\s*\]?(\s*[\-]\s*)(?P<title>.*)(\s*[\-]\s*)(?P<author>.*)`)
var str = `Bluewater Bay 10 - Rain Shadow - L A Witt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}