import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[?(?P<series>[^0-9]+)(?P<episode>\\[?\\d+\\]?)\\s*\\]?(\\s*[\\-]\\s*)(?P<title>.*)(\\s*[\\-]\\s*)(?P<author>.*)";
final String string = "Bluewater Bay 10 - Rain Shadow - L A Witt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}