const regex = /\[?(?P<series>[^0-9]+)(?P<episode>\[?\d+\]?)\s*\]?(\s*[\-]\s*)(?P<title>.*)(\s*[\-]\s*)(?P<author>.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[?(?P<series>[^0-9]+)(?P<episode>\\[?\\d+\\]?)\\s*\\]?(\\s*[\\-]\\s*)(?P<title>.*)(\\s*[\\-]\\s*)(?P<author>.*)', 'gmi')
const str = `Bluewater Bay 10 - Rain Shadow - L A Witt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}