package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-\s([^\(]+)`)
var str = `S-1 - Wealthbridge Acquisition Ltd (0001753673) (Filer)
S-1/A - KinerjaPay Corp. (0001494162) (Filer)
S-1 - CYTY CAPITAL SOLUTIONS INC (0001762609) (Filer)
S-1/A - NORTHWEST OIL & GAS TRADING COMPANY, INC. (0001762533) (Filer)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}