use strict;
my $str = 'S-1 - Wealthbridge Acquisition Ltd (0001753673) (Filer)
S-1/A - KinerjaPay Corp. (0001494162) (Filer)
S-1 - CYTY CAPITAL SOLUTIONS INC (0001762609) (Filer)
S-1/A - NORTHWEST OIL & GAS TRADING COMPANY, INC. (0001762533) (Filer)';
my $regex = qr/-\s([^\(]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}