$re = '/-\s([^\(]+)/m';
$str = 'S-1 - Wealthbridge Acquisition Ltd (0001753673) (Filer)
S-1/A - KinerjaPay Corp. (0001494162) (Filer)
S-1 - CYTY CAPITAL SOLUTIONS INC (0001762609) (Filer)
S-1/A - NORTHWEST OIL & GAS TRADING COMPANY, INC. (0001762533) (Filer)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);