import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\s([^\\(]+)";
final String string = "S-1 - Wealthbridge Acquisition Ltd (0001753673) (Filer)\n"
+ "S-1/A - KinerjaPay Corp. (0001494162) (Filer)\n"
+ "S-1 - CYTY CAPITAL SOLUTIONS INC (0001762609) (Filer)\n"
+ "S-1/A - NORTHWEST OIL & GAS TRADING COMPANY, INC. (0001762533) (Filer)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}