#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[url]=.*?\](.*)\[/url]"
Local $sString = " [url=http://filesflash.net/7f7kvqfm]http://filesflash.net/7f7kvqfm[/url]" & @CRLF & _
" [url=http://filesflash.net/s4b1wwqs]http://filesflash.net/s4b1wwqs[/url]" & @CRLF & _
" [url=http://filesflash.net/op5bmtg1]http://filesflash.net/op5bmtg1[/url]"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)