using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url]=.*?\](.*)\[/url]";
string substitution = @"\1";
string input = @" [url=http://filesflash.net/7f7kvqfm]http://filesflash.net/7f7kvqfm[/url]
[url=http://filesflash.net/s4b1wwqs]http://filesflash.net/s4b1wwqs[/url]
[url=http://filesflash.net/op5bmtg1]http://filesflash.net/op5bmtg1[/url]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}