import re
regex = re.compile(r"\[url]=.*?\](.*)\[/url]")
test_str = (" [url=http://filesflash.net/7f7kvqfm]http://filesflash.net/7f7kvqfm[/url]\n"
" [url=http://filesflash.net/s4b1wwqs]http://filesflash.net/s4b1wwqs[/url]\n"
" [url=http://filesflash.net/op5bmtg1]http://filesflash.net/op5bmtg1[/url]")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)