import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[url]=.*?\\](.*)\\[/url]";
final String string = " [url=http://filesflash.net/7f7kvqfm]http://filesflash.net/7f7kvqfm[/url]\n"
+ " [url=http://filesflash.net/s4b1wwqs]http://filesflash.net/s4b1wwqs[/url]\n"
+ " [url=http://filesflash.net/op5bmtg1]http://filesflash.net/op5bmtg1[/url]";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}