$re = '/\[url]=.*?\](.*)\[/url]/';
$str = ' [url=http://filesflash.net/7f7kvqfm]http://filesflash.net/7f7kvqfm[/url]
[url=http://filesflash.net/s4b1wwqs]http://filesflash.net/s4b1wwqs[/url]
[url=http://filesflash.net/op5bmtg1]http://filesflash.net/op5bmtg1[/url]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;