#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\S+?)?(_{2,3}(\S+)?)?_\.zip"
Local $sString = "Action_Girlz_Racing__Europe_.zip" & @CRLF & _
                "Guitar_Hero_-_Warriors_of_Rock__Europe___En_Fr_De_Es_It_.zip" & @CRLF & _
                "Guitar_Hero_5__Europe___En_Fr_De_Es_It_.zip" & @CRLF & _
                "Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.00_.zip" & @CRLF & _
                "Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.01_.zip" & @CRLF & _
                "Yu-Gi-Oh__5D_s_-_Wheelie_Breakers__Europe___En_Fr_De_Es_It_.zip" & @CRLF & _
                "AFL__Australia_.zip" & @CRLF & _
                "Sesame_Street_-_Ready__Set__Grover___Australia_.zip" & @CRLF & _
                "uDraw_Pictionary__Australia_.zip" & @CRLF & _
                "X_Factor__The__Europe___En_Fr_De_It_Nl_.zip" & @CRLF & _
                "uDraw_Disney_Princess_-_Enchanting_Storybooks__Europe__Australia___En_Fr_De_Es_It_Nl_.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")