const regex = /(\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\S+?)?(_{2,3}(\S+)?)?_\.zip/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\\S+?)?(_{2,3}(\\S+)?)?_\\.zip', 'gm')
const str = `Action_Girlz_Racing__Europe_.zip
Guitar_Hero_-_Warriors_of_Rock__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_5__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.00_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.01_.zip
Yu-Gi-Oh__5D_s_-_Wheelie_Breakers__Europe___En_Fr_De_Es_It_.zip
AFL__Australia_.zip
Sesame_Street_-_Ready__Set__Grover___Australia_.zip
uDraw_Pictionary__Australia_.zip
X_Factor__The__Europe___En_Fr_De_It_Nl_.zip
uDraw_Disney_Princess_-_Enchanting_Storybooks__Europe__Australia___En_Fr_De_Es_It_Nl_.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}