import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\\S+?)?(_{2,3}(\\S+)?)?_\\.zip";
final String string = "Action_Girlz_Racing__Europe_.zip\n"
+ "Guitar_Hero_-_Warriors_of_Rock__Europe___En_Fr_De_Es_It_.zip\n"
+ "Guitar_Hero_5__Europe___En_Fr_De_Es_It_.zip\n"
+ "Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.00_.zip\n"
+ "Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.01_.zip\n"
+ "Yu-Gi-Oh__5D_s_-_Wheelie_Breakers__Europe___En_Fr_De_Es_It_.zip\n"
+ "AFL__Australia_.zip\n"
+ "Sesame_Street_-_Ready__Set__Grover___Australia_.zip\n"
+ "uDraw_Pictionary__Australia_.zip\n"
+ "X_Factor__The__Europe___En_Fr_De_It_Nl_.zip\n"
+ "uDraw_Disney_Princess_-_Enchanting_Storybooks__Europe__Australia___En_Fr_De_Es_It_Nl_.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}