import Foundation
let pattern = #"(\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\S+?)?(_{2,3}(\S+)?)?_\.zip"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Action_Girlz_Racing__Europe_.zip
Guitar_Hero_-_Warriors_of_Rock__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_5__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.00_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.01_.zip
Yu-Gi-Oh__5D_s_-_Wheelie_Breakers__Europe___En_Fr_De_Es_It_.zip
AFL__Australia_.zip
Sesame_Street_-_Ready__Set__Grover___Australia_.zip
uDraw_Pictionary__Australia_.zip
X_Factor__The__Europe___En_Fr_De_It_Nl_.zip
uDraw_Disney_Princess_-_Enchanting_Storybooks__Europe__Australia___En_Fr_De_Es_It_Nl_.zip
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)