$re = '/(\S+?)(?=_{2,3})_{1,}(Europe|UK|Netherlands|Scandinavia|Spain|France|Germany|Australia)_{0,3}(\S+?)?(_{2,3}(\S+)?)?_\.zip/m';
$str = 'Action_Girlz_Racing__Europe_.zip
Guitar_Hero_-_Warriors_of_Rock__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_5__Europe___En_Fr_De_Es_It_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.00_.zip
Guitar_Hero_III_-_Legends_of_Rock__Europe___En_Fr_De_Es_It___v1.01_.zip
Yu-Gi-Oh__5D_s_-_Wheelie_Breakers__Europe___En_Fr_De_Es_It_.zip
AFL__Australia_.zip
Sesame_Street_-_Ready__Set__Grover___Australia_.zip
uDraw_Pictionary__Australia_.zip
X_Factor__The__Europe___En_Fr_De_It_Nl_.zip
uDraw_Disney_Princess_-_Enchanting_Storybooks__Europe__Australia___En_Fr_De_Es_It_Nl_.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);